Problem when upgrading to 3.3.1

Community Support for Booked Scheduler
Post Reply
dimitrism
Posts: 4
Joined: Thu Nov 25, 2021 8:04 pm

Problem when upgrading to 3.3.1

Post by dimitrism »

When trying to upgrade from 3.3.0 to 3.3.1, just at the final step (the database schema upgrade),
I login at ...../Web/install/ and I provide the correct "install password".
Then, all of a sudden, a page appers with just the message "Install Booked Scheduler".
No db user, no db password asked!
Even though the footer refers to "Booked Scheduler v3.3.1", I cannot even login to my system!
Is this a bug? Anyone installed successfully 3.3.1?

dimitrism
Posts: 4
Joined: Thu Nov 25, 2021 8:04 pm

Re: Problem when upgrading to 3.3.1

Post by dimitrism »

If anybody from the developers follows the forum, it might be helpful to provide him/her the below info, regarding the above problem:

After the upgrade from version 3.3.0 to version 3.3.1, the initial login page loads, however some files are coming with protocol h3 (HTTP/3) while other files are coming with protocol h2 (HTTP/2).
(The apache2 server has been customized to handle protocol h2 (HTTP/2) for many years.)
Specifically, the observed files coming with HTTP/3 are:
  • css2?family=Nunito+Sans:wght@200;300;400;600;700&display=swap
  • bootstrap-icons@1.7.2/font/bootstrap-icons.css
  • bootstrap@5.1.3/dist/css/bootstrap.min.css
Is this behavior related to the upgrade problem?

Meric
Posts: 2
Joined: Wed Sep 23, 2020 2:16 pm

Re: Problem when upgrading to 3.3.1

Post by Meric »

Hello,
I tried to upgrade from 3.2.1 to 3.3.1 and same problem.
I have a lot of PHP warning messages from files in tpl_c:
PHP message: PHP Warning: Undefined array key "ShowScriptUrlWarning" in some_dir/tpl_c/ede0ba0ac81ed269b7beef11b24be76e857ba096_0.file.install.tpl.php

Post Reply